lkml.org 
[lkml]   [2007]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.6.24 regression: hibernation hangs on "Suspending console" in low-battery condition
Date
On Sunday 11 November 2007, Rafael J. Wysocki wrote:
> On Sunday, 11 of November 2007, Andrey Borzenkov wrote:
> > On Monday 05 November 2007, Andrey Borzenkov wrote:
> > > Notice "hung" not "hangs". This happened so far only once - when low battery
> > > condition triggered suspend to disk. I was not able to reproduce it after
> > > this running on AC.
> > >
> > > Just in case it rings the bell for someone. This is not suspend regression
> > > reported earlier by Jens - I do not even have SATA nor is using libata
> > > drivers.
> > >
> >
> > This happened second time, now with 2.6.24-rc2. I have kpowersave configured
> > to initiate suspend-to-disk on low battery. Suspend-to-disk is initiated,
> > but system stops after Suspending console line. Suspend image is not created.
> >
> > This did work before although I do not name exact version.
> >
> > I am rather at loss how to proceed further ... any idea? dmesg and config
> > attached just in case. The problem is that hibernation works when I initiate
> > it manually ...
>
> Have you tried it with the battery removed?
>
>

It works. Subjectively I have relatively long pause after first Suspending console
message (where it hangs otherwise), according to dmesg timestamp it is about
1 second before next messages appear. Also last two times I tried it writeout
of suspend image was really slow; it was both with and without battery. Reading
on resume in really in order of magnitude faster.

But manual STD so far works both on AC (with or without battery) or on battery.

Of course it is possible that battery gets exhausted during STD, but system
is not switched off. Rather I would suspect something like ACPI notification
that comes during freeze ...

If someone can advice which options to enable I could try netconsole. But likely
not before next weekend.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2007-11-11 19:51    [W:0.046 / U:0.032 seconds]
©2003-2014 Jasper Spaans. Advertise on this site