[lkml]   [2007]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [patch 1/4] spinlock: lockbreak cleanup
    On Thu, 2007-11-01 at 15:02 +0100, Nick Piggin wrote:

    > Rename need_lockbreak to spin_needbreak, make it use spin_is_contended to
    > decouple it from the spinlock implementation, and make it typesafe (rwlocks
    > do not have any need_lockbreak sites -- why do they even get bloated up
    > with that break_lock then?).

    IIRC Lee has a few patches floating about that do introduce lockbreak
    stuff for rwlocks.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-11-01 15:09    [from the cache]
    ©2003-2014 Jasper Spaans. hosted at Digital Ocean