lkml.org 
[lkml]   [2007]   [Oct]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: Bug #4580: hda: lost interrupt when resuming from S3 - Sony VGN-T1XP
    Date

    Hi,

    On Sunday 07 October 2007, Rafael J. Wysocki wrote:
    > Hi,
    >
    > IDE/ATA wizzards are kindly requested to have a look at:
    >
    > http://bugzilla.kernel.org/show_bug.cgi?id=4580#c21
    >
    > as I have no idea of what we can do about the "hard drive password vs suspend"
    > problem, if anything.

    CONFIG_BLK_DEV_IDEACPI=y is not enough since IDE ACPI _GTF support is disabled
    by default. To enable it "ide=acpigtf" kernel parameter should be used.

    Sometimes it may be also worth to try enabling usage of IDE ACPI methods on
    boot ("ide=acpionboot" kernel parameter) which is also disabled by default.

    We probably should switch both options to be on by default if recent libata
    transition to ACPI on by default turns out to be successful.

    PS I've updated bug #4580 accordingly.

    Thanks,
    Bart
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-10-08 23:43    [W:0.023 / U:126.268 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site