[lkml]   [2007]   [Oct]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [PATCH RFC REPOST 1/2] paravirt: refactor struct paravirt_ops into smaller pv_*_ops
    Rusty Russell wrote:
    > Sure, but this can actually be a temporary thing inside the patch code (or at
    > least static to that file if it's too big for the stack).
    > struct paravirt_ops patch_template = { .pv_info = pv_info, .pv_cpu_ops =
    > pv_cpu_ops, ... };
    > Then you can even rename struct paravirt_ops to "struct patch_template" and
    > we're well on the way to making this a generic function-call patching
    > mechanism, rather than something paravirt-specific.

    Hm, I see. I'm not quite sure that's the best way to achieve a generic
    result, but I see your point.

    > Hope that clarifies my thinking...

    Well, I'd agree with making the code more generic if another user
    appears, but I'd rather not do it prematurely.

    Sorry, I forgot to update lguest. I'll do that and repost (but I won't
    have had a chance to test it).

    Are you otherwise happy with the patch in its current form? And are you
    happy with the lazymode changes?


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2007-10-12 21:19    [W:0.021 / U:1.252 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site