lkml.org 
[lkml]   [2007]   [Jan]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [2.6.18.2] ide_core bug: kobject_add failed for ide ...
    From
    Date
    On Sun, 2007-01-07 at 18:44 +0100, Andreas Hartmann wrote:
    > Hello,
    >
    > ide_core is loaded (while putting in an USB stick) as module the first
    > time after reboot - all works fine. The USB stick got mounted and a ls
    > is done to show the files on the root of the filesystem of the stick.
    > Afterwards, the stick is securely removed from the system.
    > Afterwards, ide_core is unloaded with rmmod (after usb-storage has been
    > unloaded) - ok.
    >
    > Next step is to load ide_core again. Now, the following error can be
    > found in /var/log/messages:
    >
    >
    > Jan 7 11:48:18 notebook1 kernel: Uniform Multi-Platform E-IDE driver
    > Revision: 7.00alpha2
    > Jan 7 11:48:18 notebook1 kernel: ide: Assuming 33MHz system bus speed
    > for PIO modes; override with idebus=xx
    > Jan 7 11:48:18 notebook1 kernel: kobject_add failed for ide with
    > -EEXIST, don't try to register things with the same name in the same
    > directory.

    You seem to be running a SuSE kernel - please report the issue to them.

    It's probably useful to repeat your test but run "find /sys/module >
    sys1" before loading ide_core the first time, then "find /sys/module >
    sys2" after "rmmod ide_core", and save the output of "diff sys1 sys2".

    Lee


    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2007-01-07 20:07    [W:0.023 / U:60.972 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site