[lkml]   [2006]   [Aug]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 2/6] rename the provided execve functions to kernel_execve
Arnd Bergmann writes:

> Some architectures provide an execve function that does not
> set errno, but instead returns the result code directly.
> Rename these to kernel_execve to get the right semantics there.
> Moreover, there is no reasone for any of these architectures to
> still provide __KERNEL_SYSCALLS__ or _syscallN macros, so
> remove these right away.
> Signed-off-by: Arnd Bergmann <>

Acked-by: Paul Mackerras <>
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-08-30 23:55    [W:0.088 / U:4.368 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site