[lkml]   [2006]   [Aug]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: [RFC][PATCH 4/4] Rename lock_cpu_hotplug/unlock_cpu_hotplug
    On Thu, 2006-08-24 at 16:04 +0530, Gautham R Shenoy wrote:
    > This patch renames lock_cpu_hotplug to cpu_hotplug_disable and
    > unlock_cpu_hotplug to cpu_hotplug_enable throughout the kernel.


    to be honest I dislike the new names too. You turned it into a refcount,
    which is good, but the normal linux name for such refcount functions is
    _get and _put..... and in addition the refcount technically isn't
    hotplug specific, all you want is to keep the kernel data for the
    processor as being "used", so cpu_get() and cpu_put() would sound
    reasonable names to me, or cpu_data_get() cpu_data_put().

    Arjan van de Ven

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2006-08-24 13:03    [W:0.028 / U:7.692 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site