lkml.org 
[lkml]   [2006]   [Apr]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] pids: simplify do_each_task_pid/while_each_task_pid
On Fri, Apr 14, 2006 at 12:21:04AM +0400, Oleg Nesterov wrote:
> #define NEW_IMPROVED_HLIST_FOR_EACH_ENTRY_RCU_WHICH_DOESNT_NEED_EXTRA_PARM(pos, head, member) \
> for (pos = hlist_entry((head)->first, typeof(*(pos)), member); \
> rcu_dereference(pos) != hlist_entry(NULL, typeof(*(pos)), member) \
> && ({ prefetch((pos)->member.next); 1; }); \
> (pos) = hlist_entry((pos)->member.next, typeof(*(pos)), member))
>
> What do you think? What should be the name for it?

Justy kill the superflous argument from all hlist_for_each_entry variants
without a name change.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-04-13 18:34    [W:0.038 / U:1.404 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site