lkml.org 
[lkml]   [2006]   [Mar]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: snd_hda_intel on 2.6.16
    At Fri, 31 Mar 2006 10:49:19 -0600,
    Alejandro Bonilla wrote:
    >
    > On Fri, 31 Mar 2006 11:40:58 -0500, Lee Revell wrote
    > > On Fri, 2006-03-31 at 10:29 -0600, Alejandro Bonilla wrote:
    > > > Hi,
    > > >
    > > > I read about a problem with snd_hda_intel latelly on 2.6.16. I was not having
    > > > this on 2.6.15-19 but looks like it is "chip-monking"
    > > >
    > >
    > > Too cryptic. What exactly is the problem?
    >
    > The sound is like at 1.2x. Just a little bit faster but noticeable.

    Faster? You mean pitch or only playback speed?
    It's the first report I've heard. Usually, the regression is either
    noisy output or silence...

    Try position_fix=1, or a different value, if the latest ALSA version
    still doesn't work.


    > > > I use linux2.6 git and it is still present. Just wanted to let you'll know
    > > > about it.
    > > >
    > > > Should anyone need any info, please let me know.
    > > >
    > >
    > > Well, for starters, your hardware info ("hda-intel" describes 1000s
    > > of slightly different devices).
    >
    > 0000:00:1b.0 0403: Intel Corporation 82801G (ICH7 Family) High Definition
    > Audio Controller (rev 02)
    > Subsystem: Hewlett-Packard Company: Unknown device 30a0
    > Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
    > Stepping- SERR- FastB2B-
    > Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-
    > <TAbort- <MAbort- >SERR- <PERR-
    > Latency: 0, Cache Line Size: 0x10 (64 bytes)
    > Interrupt: pin A routed to IRQ 50
    > Region 0: Memory at d8240000 (64-bit, non-prefetchable) [size=16K]
    > Capabilities: [50] Power Management version 2
    > Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA
    > PME(D0+,D1-,D2-,D3hot+,D3cold+)
    > Status: D0 PME-Enable- DSel=0 DScale=0 PME-
    > Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
    > Address: 0000000000000000 Data: 0000
    > Capabilities: [70] #10 [0091]
    >
    > Pretty much, I almost only know it is Conexant.

    Better check /proc/asound/card0/codec#* files.

    Sigh, Conexant. It's a problematic one. They don't give any
    technical information.

    > >
    > > Does it work with the latest ALSA CVS or 1.0.11-rc4?
    >
    > I don't know. It was working with 2.6.15-X


    Any other changes on your system except for kernel?


    Takashi
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2006-03-31 19:50    [W:0.026 / U:29.268 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site