lkml.org 
[lkml]   [2006]   [Mar]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: [patch 3/8] use list_add_tail() instead of list_add()
On Thu, Mar 30, 2006 at 04:16:08PM +0800, Akinobu Mita wrote:

This patch converts list_add(A, B.prev) to list_add_tail(A, &B)
for readability.

Acked-by: Karsten Keil <kkeil@suse.de>
for the ISDN/CAPI part.


CC: Jan Harkes <jaharkes@cs.cmu.edu>
CC: Jan Kara <jack@suse.cz>
CC: David Woodhouse <dwmw2@infradead.org>
CC: Sridhar Samudrala <sri@us.ibm.com>
Signed-off-by: Akinobu Mita <mita@miraclelinux.com>

drivers/isdn/capi/capi.c | 2 +-
fs/coda/psdev.c | 2 +-
fs/coda/upcall.c | 2 +-
fs/dcache.c | 2 +-
fs/dquot.c | 4 ++--
fs/jffs2/compr.c | 4 ++--
net/sctp/outqueue.c | 2 +-
7 files changed, 9 insertions(+), 9 deletions(-)

Index: 2.6-git/drivers/isdn/capi/capi.c
===================================================================
--- 2.6-git.orig/drivers/isdn/capi/capi.c
+++ 2.6-git/drivers/isdn/capi/capi.c
@@ -238,7 +238,7 @@ static struct capiminor *capiminor_alloc

if (minor < capi_ttyminors) {
mp->minor = minor;
- list_add(&mp->list, p->list.prev);
+ list_add_tail(&mp->list, &p->list);
}
}
write_unlock_irqrestore(&capiminor_list_lock, flags);


--
Karsten Keil
SuSE Labs
ISDN development
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-03-30 10:28    [W:0.106 / U:0.084 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site