lkml.org 
[lkml]   [2006]   [Mar]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] for_each_possible_cpu [1/19] defines for_each_possible_cpu
KAMEZAWA Hiroyuki <kamezawa.hiroyu@jp.fujitsu.com> wrote:
>
> Now,
> for_each_cpu() is for-loop cpu over cpu_possible_map.
> for_each_online_cpu is for-loop cpu over cpu_online_map.
> .....for_each_cpu() looks bad name.
>
> This patch renames for_each_cpu() as for_each_possible_cpu().
>

Sane.

> I also wrote patches to replace all for_each_cpu with for_each_possible_cpu.
> please confirm....
>
> BTW, when HOTPLUC_CPU is not suppoted, using for_each_possible_cpu()
> should be avoided, I think.

Sometimes. Sometimes it's valid though - allocating (small amounts of)
per-cpu storage, summing up per-cpu counters (poorly), etc.

> -#define for_each_cpu(cpu) for_each_cpu_mask((cpu), cpu_possible_map)
> +#define for_each_possible_cpu(cpu) for_each_cpu_mask((cpu), cpu_possible_map)

Nope, I'll change this to

#define for_each_cpu(cpu) for_each_cpu_mask((cpu), cpu_possible_map)
#define for_each_possible_cpu(cpu) for_each_cpu_mask((cpu), cpu_possible_map)

So both are valid. That way

a) The kernel continues to compile at each step of the patch series
(important!) and

b) We can remove for_each_cpu() later on, after all the various
out-of-tree usages have been converted.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-03-16 04:45    [W:0.072 / U:0.252 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site