lkml.org 
[lkml]   [2006]   [Feb]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [x86_64] bttv: linux 2.6.16-rc1 mplayer fails to record ALSA audio and fails tune TV.
Hi,

status update, it's still like this; I probably don't have much time
to sit around debugging this problem myself, but if anyone else has
met this problem and fixed it, I'd be delighted to know about it.

Linux dancer64 2.6.16-rc1dancer-ga6df590d-dirty #1 Wed Feb 1 18:36:00 JST 2006 x86_64 GNU/Linux


regards,
junichi
--
dancer@{debian.org,netfort.gr.jp} Debian Project


At Fri, 20 Jan 2006 08:11:34 +0900,
Junichi Uekawa wrote:
>
> Hi,
>
> With 2.6.16-rc1, it's recording no audio, and it's recording
> black-and-white noise on video. Wooo, it's getting worse.
>
> $ uname -a
> Linux dancer64 2.6.16-rc1dancer-dirty #1 Wed Jan 18 08:11:24 JST 2006 x86_64 GNU/Linux
>
>
> From the information that I've gathered so far it seems like:
> 1. bttv was rewritten to support v4l2
> 2. record via v4l2 is broken, v4l1 is not (xawtv works, mencoder broken.)
> I've heard mencoder should work with v4l1, but I have not yet confirmed.
>
> bttv-cards.c:
>
> [BTTV_BOARD_GVBCTV5PCI] = {
> .name = "IODATA GV-BCTV5/PCI",
> .video_inputs = 3,
> .audio_inputs = 1,
> .tuner = 0,
> .svhs = 2,
> .gpiomask = 0x0f0f80,
> .muxsel = {2, 3, 1, 0 },
> .audiomux = {0x030000, 0x010000, 0, 0, 0x020000, 0},
> .no_msp34xx = 1,
> .pll = PLL_28,
> .tuner_type = TUNER_PHILIPS_NTSC_M,
> .tuner_addr = ADDR_UNSET,
> .radio_addr = ADDR_UNSET,
> .audio_hook = gvbctv5pci_audio,
> .has_radio = 1,
> },
>
> dmesg gives me an impression that this path is taken properly:
> bttv: driver version 0.9.16 loaded
> bttv: using 8 buffers with 2080k (520 pages) each for capture
> bttv: Bt8xx card found (0).
> bttv0: Bt878 (rev 17) at 0000:03:0b.0, irq: 22, latency: 64, mmio: 0xfdcff000
> bttv0: detected: I-O Data Co. GV-BCTV5/PCI [card=81], PCI subsystem ID is 10fc:d018
> bttv0: using: IODATA GV-BCTV5/PCI [card=81,autodetected]
> bttv0: gpio: en=00000000, out=00000000 in=00f6f0f7 [init]
> bttv0: using tuner=17
> bttv0: i2c: checking for TDA9875 @ 0xb0... not found
> bttv0: i2c: checking for TDA7432 @ 0x8a... not found
> bttv0: i2c: checking for TDA9887 @ 0x86... not found
> tuner 0-0061: chip found @ 0xc2 (bt878 #0 [sw])
> tuner 0-0061: type set to 17 (Philips NTSC_M (MK2))
> bttv0: registered device video0
> bttv0: registered device vbi0
> bttv0: registered device radio0
> bttv0: PLL: 28636363 => 35468950 .. ok
>
>
> v4l-info is dumped with:
>
> printf("inputs\n");
> for (i = 0;; i++) {
> memset(&input,0,sizeof(input));
> input.index = i;
> if (-1 == ioctl(fd,VIDIOC_ENUMINPUT,&input))
> break;
> printf(" VIDIOC_ENUMINPUT(%d)\n",i);
> print_struct(stdout,desc_v4l2_input,&input,"",tab);
> }
> printf("\n");
>
>
> which is probably handled in
> bttv-driver.c:static int bttv_common_ioctls(struct bttv *btv, unsigned int cmd, void *arg)
>
> which unconditionally sets:
> i->audioset = 0;
>
>
>
> > last successful one was 2.6.14-rc5.
> >
> >
> > I've noticed that there is a v4l-info command, which dumps v4l2
> > information, and it seems to signify that v4l2 is giving a different
> > answer.
> >
> > The following is a diff, which seems to signify that this difference
> > exists in the two versions:
> >
> > - audioset : 1
> > + audioset : 0
> >
>
>
> regards,
> junichi
> --
> dancer@{debian.org,netfort.gr.jp} Debian Project
>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-02-02 10:16    [W:0.123 / U:0.128 seconds]
©2003-2011 Jasper Spaans. Advertise on this site