lkml.org 
[lkml]   [2006]   [Feb]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: No sound from SB live!
Date
On Sunday 19 February 2006 23:32, Lee Revell wrote:
> On Sun, 2006-02-19 at 23:23 +0000, Alistair John Strachan wrote:
> > I'm still using 1.0.9 on 2.6.16-rc4 with no problems, Audigy 2 (one
> > that uses
> > emu10k1).
>
> It's a specific change to the SBLive! that did not affect the Audigy
> that causes alsa-lib 1.0.10+ to be required on 2.6.14 and up. These
> types of incompatible changes should be rare.
>
> It was a necessary precursor to fixing the well known "master volume
> only controls front speakers" bug.

Thanks for this info Lee, and understand I don't hold anybody specifically in
the alsa team responsible but *deep breath*:

Please let everybody know about incompatible changes to alsa-lib know about it
prior to making the change mandatory.

This means immediately update http://www.alsa-project.org/ with the
information. I do not mean add a one-liner to the changelog.

ALSA's great and I wholeheartedly support it, but this sort of thing cannot
happen without informing people about the requirement. Expecting people to
"just upgrade" is frankly not acceptable. At all. We're not using Rawhide.

--
Cheers,
Alistair.

'No sense being pessimistic, it probably wouldn't work anyway.'
Third year Computer Science undergraduate.
1F2 55 South Clerk Street, Edinburgh, UK.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-02-20 00:58    [from the cache]
©2003-2011 Jasper Spaans. Advertise on this site