[lkml]   [2006]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: lots of code could be simplified by using ARRAY_SIZE()

    > there are numerous places throughout the source tree that apparently
    > calculate the size of an array using the construct
    > "sizeof(fubar)/sizeof(fubar[0])". see for yourself:
    > $ grep -Er "sizeof\((.*)\) ?/ ?sizeof\(\1\[0\]\)" *
    > but we already have, from "include/linux/kernel.h":
    > #define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))

    Hmmm. quite misleading name :-(. ARRAY_LEN would be better.

    Thanks for all the (sleeping) penguins.
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2006-12-16 09:43    [W:0.020 / U:5.564 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site