[lkml]   [2006]   [Dec]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [take26-resend1 0/8] kevent: Generic event handling mechanism.

* [oh, everybody will hate me for saying this, but...] to me, "kevent"
implies an internal kernel subsystem. I would rather call it "uevent"
or anything else lacking a 'k' prefix.

* I like the absolute timespec (and use of timespec itself)

* more on naming: I think kevent_open would be more natural than
kevent_init, since it opens a file descriptor.

* why is KEVENT_MAX not equal to KEVENT_POSIX_TIMER? (perhaps answer
this question in a comment, if it is not a mistake)

* Kill all the CONFIG_KEVENT_xxx sub-options, or hide them under
CONFIG_EMBEDDED. Application developers should NOT be left wondering
whether or support for KEVENT_INODE was compiled into the kernel.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-12-11 16:19    [W:0.684 / U:1.088 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site