[lkml]   [2006]   [Nov]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: 2.6.19-rc3 system freezes when ripping with cdparanoia at ioctl(SG_IO)
    ens Axboe wrote:
    > On Mon, Oct 30 2006, Gregor Jasny wrote:
    >> 2006/10/30, Jens Axboe <>:
    >>> Can you confirm that 2.6.18 works?
    >> The reporter of [1] states that his SATA Thinkpad freezes with 2.6.17
    >> and 2.6.18, too.
    >> Gregor
    >> [1]
    > Ok, mainly just checking if this was a potential dupe of another bug.

    Jens (or anybody else who has any idea of how to debug this),

    Did you have a chance to reproduce the problem? I guess we "only" need a
    machine with SATA/ata_piix and cdparanoia 3.10. If you want me to debug
    some stuff, feel free to tell me what. But, since it freezes the machine
    and sysrq doesn't even work, I don't really know what to try...

    I just tried on rc5 and rc5-mm1, both have the problem (as 2.6.16, .17
    and .18 do, don't know about earlier kernels). I didn't have a audio CD
    here, so I tried abcde on a DVD on purpose. With cdparanoia 3.10-pre0
    (from Debian testing), it reports nothing during about 5 seconds and
    then the machine freezes. With cdparanoia 3a9.8-11 (from Debian stable),
    it reports an error very quickly, and dmesg gets a couple line like these:
    sg_write: data in/out 12/12 bytes for SCSI command 0x43--guessing
    data in;
    program cdparanoia not setting count and/or reply_len properly


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2006-11-09 10:49    [W:0.025 / U:2.916 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site