lkml.org 
[lkml]   [2006]   [Nov]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [Patch -mm 2/2] driver core: Introduce device_move(): move a device to a new parent.
From
Date
On Thu, 2006-11-16 at 15:42 +0100, Cornelia Huck wrote:
> From: Cornelia Huck <cornelia.huck@de.ibm.com>
>
> Provide a function device_move() to move a device to a new parent device. Add
> auxilliary functions kobject_move() and sysfs_move_dir().
> kobject_move() generates a new uevent of type KOBJ_MOVE, containing the
> previous path (OLD_DEVPATH) in addition to the usual values.

> + sprintf(devpath_string, "OLD_DEVPATH=%s", devpath);

I think it's easier to understand, if the variable starts with the same
string as original name. I prefer DEVPATH_OLD.

> +void kobject_uevent_extended(struct kobject *kobj, enum kobject_action action,
> + const char *string)

I think we should pass an array of env vars here instead of a single
string - you never know ... :) The function could probably be named
kobject_uevent_env() then.

Thanks,
Kay

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-16 17:51    [from the cache]
©2003-2011 Jasper Spaans