lkml.org 
[lkml]   [2006]   [Nov]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: unexplainable read errors, copy/diff-issue
    Some additional notes:
    1)
    I just have had an PCI parity error (exactly on),.. but I don't think
    that this is really an error or a damage.
    It (the error) happens exactly when I activate PCI parity checking (echo
    1 > /sys/devices/system/edac/pci/check_pci_parity).
    (I've tested this several times, so this is fully reproducable.)
    This is the message:
    EDAC PCI: Bridge Detected Parity Error on 0000:00:09.0

    lscpi says:
    00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)

    Note that the following still applys: When doing the diffs and errors
    occur,.. NO PCI parity error or memory errors are logged. And mcelog
    still prints (really) nothing.

    I should perhaps inform the authors of edac about that issue.


    2)
    I just tried the whole procedure from Knoppix 4.0 (which has a kernel
    2.6.12).
    It seems that it does not recognize most of my hardware (i.e. chipset
    drivers for IDE and so on)...
    So at first the diff runned for quite a time in non-DMA mode (which I
    found out when I wondered why it took so long).
    I then did a echo using_dma:1 > /proc/ide.../settings,... which
    apperently worked,.. and nearly immediately after this,.. a difference
    was found.
    (But perhaps this was only by fortune). I aborted the test any do the
    whole thing (with dma off) under my normal system.

    Can anybody imagine that DMA could cause my problems? And if so,.. is it
    likely that this would come from a hardware error or maybe from software?

    Regards,
    Chris.
    begin:vcard
    fn:Mitterer, Christoph Anton
    n:Mitterer;Christoph Anton
    email;internet:calestyo@scientia.net
    x-mozilla-html:TRUE
    version:2.1
    end:vcard

    \
     
     \ /
      Last update: 2006-11-13 00:35    [W:0.022 / U:0.232 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site