lkml.org 
[lkml]   [2006]   [Nov]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: fc6 kernel 2.6.18-1.2798 breaks acpi on HP laptop n5430
Stephen Clark wrote:

>Dave Jones wrote:
>
>
>
>>On Wed, Nov 01, 2006 at 04:17:50PM -0500, Stephen Clark wrote:
>>
>>
>>
>>>BIOS-provided physical RAM map:
>>> BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
>>> BIOS-e820: 000000000009f000 - 0000000000100000 (reserved)
>>> BIOS-e820: 0000000000100000 - 000000001fff0000 (usable)
>>> BIOS-e820: 000000001fff0000 - 000000001ffff000 (ACPI data)
>>> BIOS-e820: 000000001ffff000 - 0000000020000000 (ACPI NVS)
>>> BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
>>>0MB HIGHMEM available.
>>>511MB LOWMEM available.
>>>Using x86 segment limits to approximate NX protection
>>>DMI 2.2 present.
>>>Using APIC driver default
>>>ACPI: PM-Timer IO Port: 0x8008
>>>Allocating PCI resources starting at 30000000 (gap: 20000000:dff80000)
>>>Detected 850.075 MHz processor.
>>>Built 1 zonelists. Total pages: 131056
>>>Kernel command line: ro root=/dev/VolGroup00/LogVol00 lapic nousb
>>>console=ttyS0,38400
>>>Local APIC disabled by BIOS -- reenabling.
>>>Found and enabled local APIC!
>>>
>>>
>>Does it make a difference if you boot with nolapic ?
>>
>> Dave
>>
>>
>>
>>
>>
>Hi Dave,
>
>booting without lapic allowed it to boot but now I get
>...
>Local APIC disabled by BIOS -- you can enable it with "lapic"
>...
>Local APIC not detected. Using dummy APIC emulation.
> which means more processor overhead - right?
>
>also cpuspeed doesn't work anymore - I don't have a cpufreq dir
>
>I don't get the following messages with kernel 2798
> powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
>Nov 1 19:33:34 joker4 kernel: powernow: SGTC: 10000
>Nov 1 19:33:34 joker4 kernel: powernow: Minimum speed 300 MHz. Maximum
>speed 850 M
>Hz.
>Nov 1 19:33:34 joker4 kernel: powernow-k8: Processor cpuid 670 not
>supported
>
>Steve
>
>
>
>
>
I removed and reinstalled the kernel, it seems FC6 upgrade
installed a 586 kernel - now the only problem I have is my
local apic is not being used.

Steve

--

"They that give up essential liberty to obtain temporary safety,
deserve neither liberty nor safety." (Ben Franklin)

"The course of history shows that as a government grows, liberty
decreases." (Thomas Jefferson)



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-11-02 02:53    [from the cache]
©2003-2011 Jasper Spaans