lkml.org 
[lkml]   [2006]   [Oct]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.6.19-rc1: forcedeth, nobody cared
Date
Am Donnerstag 05 Oktober 2006 19:30 schrieb Fatih Aşıcı:
> 2006/10/5, Prakash Punnoor <prakash@punnoor.de>:
> > Hi,
> >
> > subjects say it all. Without irqpoll my nic doesn't work anymore. I added
> > Ingo
> > to cc, as my IRQs look different, so it may be a prob of APIC routing or
> > the
> > like.

> > Can you try booting with pci=nomsi ? I have a similar problem with my

I used snd-hda-intel.disable_msi=1 and this actually helped! Now the nforce
nic works w/o problems. So it was the audio driver causing havoc on the nic.
But (I noticed this with the kernel booted with irqpoll, as well) IRQ
balancing seems not to work anymore:

CPU0 CPU1
0: 53826 0 IO-APIC-edge timer
1: 66 0 IO-APIC-edge i8042
7: 0 0 IO-APIC-edge parport0
8: 0 0 IO-APIC-edge rtc
9: 0 0 IO-APIC-fasteoi acpi
12: 1650 0 IO-APIC-edge i8042
14: 63 0 IO-APIC-edge ide0
16: 2095 0 IO-APIC-fasteoi nvidia
19: 6 0 IO-APIC-fasteoi ohci1394
20: 0 0 IO-APIC-fasteoi ohci_hcd:usb1
21: 66 0 IO-APIC-fasteoi ehci_hcd:usb2
22: 5652 0 IO-APIC-fasteoi libata
23: 5105 0 IO-APIC-fasteoi HDA Intel, eth0
NMI: 155 75
LOC: 53715 53649
ERR: 0


--
(°= =°)
//\ Prakash Punnoor /\\
V_/ \_V
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2006-10-05 23:11    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site