[lkml]   [2006]   [Oct]   [28]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2] Re: Battery class driver.
On Sat, 2006-10-28 at 18:55 +0000, Pavel Machek wrote:
> Bad idea... I bet someone will just ignore the units part, because all
> the machines he seen had mW there.
Sure, user space can do silly things. Just ask davej. Let's try to
assume they don't.

> Just put it into the name:
> power_avg_mV

Bad idea... it means user space will have to try to open different files
and what happens when someone introduces a new unit? Ideally I'd like
the unit to be part of the payload of the sysfs file. Second to that I
think having the unit in a separate file is preferable.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2006-10-28 21:57    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean