lkml.org 
[lkml]   [2006]   [Oct]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC: 2.6.19 patch] snd-hda-intel: default MSI to off
At Tue, 17 Oct 2006 14:29:57 -0700,
Randy Dunlap wrote:
>
> On Tue, 17 Oct 2006 23:13:01 +0200 Adrian Bunk wrote:
>
> > On Thu, Oct 05, 2006 at 11:08:57PM +0200, Prakash Punnoor wrote:
> > > Am Donnerstag 05 Oktober 2006 19:30 schrieb Fatih A????c??:
> > > > 2006/10/5, Prakash Punnoor <prakash@punnoor.de>:
> > > > > Hi,
> > > > >
> > > > > subjects say it all. Without irqpoll my nic doesn't work anymore. I added
> > > > > Ingo
> > > > > to cc, as my IRQs look different, so it may be a prob of APIC routing or
> > > > > the
> > > > > like.
> > >
> > > > > Can you try booting with pci=nomsi ? I have a similar problem with my
> > >
> > > I used snd-hda-intel.disable_msi=1 and this actually helped! Now the nforce
> > > nic works w/o problems. So it was the audio driver causing havoc on the nic.
> > >...
> >
> > Unless someone finds and fixes what causes such problems, I'd therefore
> > suggest the patch below to let MSI support to be turned off by default.
>
> MSI works with my sound, ethernet, and SATA:
>
> 66: 1131814 0 PCI-MSI libata
> 98: 89556 0 PCI-MSI HDA Intel
> 106: 943530 0 PCI-MSI eth0
>
> so maybe this should be done for nforce chipsets or
> whatever is seeing the problem?

I agree that this is pretty much depending on the hardware, so
disabling all might be exaggerated.
The sound with MSI works on all of my test machines with Intel
chipset, so far.


Takashi
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2006-10-18 10:03    [from the cache]
©2003-2011 Jasper Spaans