lkml.org 
[lkml]   [2006]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [2.6 patch] schedule obsolete OSS drivers for removal
    Hannu Savolainen wrote:
    >
    > Btw, about the current OSS drivers in the kernel. They are really obsolete
    > because they are based on some 10 years old API version. For this reason
    > it's necessary to remove them in the nearish future (maybe at the same
    > time when we release the OpenOSS version). Comparing ALSA against the
    > kernel OSS drivers is pointless because current OSS has very little
    > common with that code.

    Hannu,

    This is the LKML. So, we are considering KERNEL code. Not some external
    binary blob. We are therefore suggesting to remove the kernel OSS
    drivers as that is all we have to compare with ALSA.
    We can't compare a binary blob with open source as the binary blob will
    never be part of mainline.
    Even you admit that the OSS drivers in the kernel mainline are "really
    obsolete", so you must agree with this thread that we should remove them.

    Only if your binary blobs are released as GPL so that they can be
    included in mainline can it really be any use to discuss them.

    James
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2006-01-06 10:56    [W:0.021 / U:1.960 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site