lkml.org 
[lkml]   [2006]   [Jan]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH 11/13] autofs4 - rename simple_empty_nolock function
This patch renames the function simple_empty_nolock to
__simple_empty in line with kernel naming conventions.

Signed-off-by: Ian Kent <raven@themaw.net>


--- linux-2.6.15-mm3/fs/autofs4/autofs_i.h.rename-simple_empty_nolock 2006-01-13 16:27:45.000000000 +0800
+++ linux-2.6.15-mm3/fs/autofs4/autofs_i.h 2006-01-13 16:28:06.000000000 +0800
@@ -200,7 +200,7 @@ static inline int simple_positive(struct
return dentry->d_inode && !d_unhashed(dentry);
}

-static inline int simple_empty_nolock(struct dentry *dentry)
+static inline int __simple_empty(struct dentry *dentry)
{
struct dentry *child;
int ret = 0;
--- linux-2.6.15-mm3/fs/autofs4/root.c.rename-simple_empty_nolock 2006-01-13 16:27:09.000000000 +0800
+++ linux-2.6.15-mm3/fs/autofs4/root.c 2006-01-13 16:28:07.000000000 +0800
@@ -343,7 +343,7 @@ static int autofs4_revalidate(struct den
spin_lock(&dcache_lock);
if (S_ISDIR(dentry->d_inode->i_mode) &&
!d_mountpoint(dentry) &&
- simple_empty_nolock(dentry)) {
+ __simple_empty(dentry)) {
DPRINTK("dentry=%p %.*s, emptydir",
dentry, dentry->d_name.len, dentry->d_name.name);
spin_unlock(&dcache_lock);
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2006-01-18 08:29    [W:0.029 / U:0.352 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site