[lkml]   [2005]   [Aug]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: lockups with netconsole on e1000 on media insertion
    On Fri, Aug 05, 2005 at 01:45:55PM +0200, Andi Kleen wrote:
    > John B?ckstrand <> writes:
    > > I've been trying to hunt down a hard lockup issue with some hardware
    > > of mine, but I've possibly hit a kernel bug instead. When using
    > > netconsole on my e1000, if I unplug the cable and then re-plug it, the
    > > machine locks up hard. It manages to print the "link up" message on
    > > the screen, but nothing after that. Now, I wonder if this is supposed
    > > to be so? I tried this on 4 different configurations, 2.6.13-rc5 and
    > > 2.6.12 with and without "noapic acpi=off", same result on all of
    > > them. I've tried with 1 and 3 other NICs in the machine at the same
    > > time.
    > I ran into the same problem some time ago on e1000. The problem was
    > that if the link doesn't come up netconsole ends up waiting forever
    > for it.

    I still don't like this fix. Yes, you're right, it should eventually
    give up. But here it gives up way too easily - 5 could easily
    translate to 5 microseconds. This is analogous to giving up on serial
    transmit if CTS is down for 5 loops.

    I'd be much happier if there were some udelay or the like in here so
    that we're not giving up on such a short timeframe.

    Mathematics is the supreme nostalgia of our time.
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-08-05 22:20    [W:0.025 / U:3.124 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site