lkml.org 
[lkml]   [2005]   [Aug]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [PATCH 2/8] namei cleanup
From
Date
> Bad names, IMO.
>

You're probably right. Can you suggest better ones?

Thanks,
Miklos

> > +static inline void dput_path(struct path *path, struct nameidata *nd)
> > +{
> > + dput(path->dentry);
> > + if (path->mnt != nd->mnt)
> > + mntput(path->mnt);
> > +}
> > +
> > +static inline void path_to_nameidata(struct path *path, struct nameidata *nd)
> > +{
> > + dput(nd->dentry);
> > + if (nd->mnt != path->mnt)
> > + mntput(nd->mnt);
> > + nd->mnt = path->mnt;
> > + nd->dentry = path->dentry;
> > +}
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-08-23 22:53    [W:0.038 / U:0.756 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site