lkml.org 
[lkml]   [2005]   [Aug]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: 2.6.12.5: psmouse mouse detection doesn't work
From
On Sun, Aug 21, 2005 at 06:42:23AM +0200, Harald Dunkel wrote:
> Hi folks,
>
> At boot time my Logitech mouse is detected as
>
> I: Bus=0011 Vendor=0002 Product=0001 Version=0000
> N: Name="PS/2 Generic Mouse"
> P: Phys=isa0060/serio1/input0
> H: Handlers=event1 ts0 mouse0
> B: EV=7
> B: KEY=70000 0 0 0 0
> B: REL=3
>
> After manually reloading psmouse I get the expected
>
> I: Bus=0011 Vendor=0002 Product=0002 Version=0049
> N: Name="PS2++ Logitech Mouse"
> P: Phys=isa0060/serio1/input0
> H: Handlers=event1 ts0 mouse0
> B: EV=7
> B: KEY=f0000 0 0 0 0
> B: REL=3
>
> Using psmouse_noext=1 at boot time does not help.
>
> How comes that this doesn't work on the first run?
>
> I asked this more than a year ago, and somebody posted
> a fix, but obviously it wasn't accepted.
>
> What needs to be done to fix this?

If psmouse is a module, you'd need to pass proto=bare as a module
parameter rather than on the kernel command line. Check `modinfo
psmouse`.

Are you sure proto=imps hasn't found its way into
/etc/modprobe.conf or so? I could imagine a distribution shipping
this way.

--
Joseph Fannin
jfannin@gmail.com

/* So there I am, in the middle of my `netfilter-is-wonderful'
talk in Sydney, and someone asks `What happens if you try
to enlarge a 64k packet here?'. I think I said something
eloquent like `fuck'. - RR */
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-08-21 07:28    [W:0.046 / U:47.192 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site