lkml.org 
[lkml]   [2005]   [Aug]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: 2.6.13-rc6-git10 test report [x86_64](WITHOUT NVIDIA MODULE)
From
On Fri, Aug 19, 2005 at 09:22:09AM -0700, Peter Buckingham wrote:

> >The machine is working quite a bit better with pci=noacpi in leu of
> >disabling ACPI in the BIOS, but there are still those nasty errors in
> >reference to the ACPI tables being broken:
> > ACPI-0362: *** Error: Looking up [\_SB_.PCI0.LNK0] in namespace,
> >AE_NOT_FOUND
> >search_node ffff8101428572c0 start_node ffff8101428572c0 return_node
> >0000000000000000
>
> since it doesn't look like you'll get a bios fix for this you may want
> to look at building a custom dsdt. the kernel can load a custom dsdt
> from an initrd/initramfs. have a look at the acpi site (acpi.sf.net?).
> they talk about what's needed to do this. basically you can get your
> dsdt from /proc/acpi/dsdt and disassemble it using the iasl tools, fix
> it and then load it with an initrd. note that this is not really a
> trivial task :-(

Also, please file a bug report against the ACPI component at
http://bugzilla.kernel.org . Ultimately the Linux ACPI component must
deal with these sorts of errors, or convince the BIOS authors not to
make them!

--
Joseph Fannin
jfannin@gmail.com

"That's all I have to say about that." -- Forrest Gump.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-08-20 23:38    [W:0.044 / U:3.524 seconds]
©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site