[lkml]   [2005]   [Jun]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRE: [2.6.12] x86-64 IO-APIC + timer doesn't work

>-----Original Message-----
>From: Andi Kleen []
>Sent: Saturday, June 18, 2005 6:34 PM
>To: Alistair John Strachan
>Pallipadi, Venkatesh
>Subject: Re: [2.6.12] x86-64 IO-APIC + timer doesn't work
>> Despite the fact that this wasn't documented in the BIOS
>update, an update for
>> my board (MS-7030 Neo Platinum by MSI) supposedly fixing
>"Fan Function"
>> actually corrects the IO-APIC and NMI bugs. I now get the
>following in dmesg
>> instead:
>> Calibrating delay loop... 3973.12 BogoMIPS (lpj=1986560)
>> Mount-cache hash table entries: 256
>> CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
>> CPU: L2 Cache: 512K (64 bytes/line)
>> CPU: AMD Athlon(tm) 64 Processor 3000+ stepping 00
>> Using local APIC timer interrupts.
>> Detected 12.561 MHz APIC timer.
>> testing NMI watchdog ... OK.
>> So I'm a happy man. Whether this is at all related to the
>problems I was
>> having before, I don't really know. If the problem doesn't
>reoccur, I could
>> very well have wasted your time.
>Hmm - I suspect I know what's happening. The older BIOS
>probably had some long
>running SMM code that breaks the BogoMips computation occasionally
>and that breaks the timer check later which relies on usable BogoMips.
>There was a patch for that from Venkatesh (because it showed on some
>other machines too), but it didn't seem to have made it into 2.6.12
>Venkatesh, can you push your calibrate_delay patch please? ?

That patch is in mm tree.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-06-19 07:01    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean