lkml.org 
[lkml]   [2005]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.6.11-rc4-mm1 (VFS: Cannot open root device "301")
Steven Cole wrote:
> Andrew Morton wrote:
>
>> Steven Cole <elenstev@mesatop.com> wrote:
>
>
>>> I am having trouble getting recent -mm kernels to boot on my test box.
>>> For 2.6.11-rc3-mm2 and 2.6.11-rc4-mm1 I get the following:
>>>
>>> VFS: Cannot open root device "301" or unknown-block(3,1)
>>> Please append a correct "root=" boot option
>>> Kernel panic - not syncing: VFS: Unable to mount root fs on
>>> unknown-block(3,1)
>>>
> [snipped]
>
>>
>> Please set CONFIG_BASE_FULL=y. Check that this causes
>> CONFIG_BASE_SMALL=0,
>> then retest.
>
>
> Yes, that worked. 2.6.11-rc4-mm1 now boots OK, but hdb1 seems to be
> missing.
>
> [root@spc1 steven]# uname -r
> 2.6.11-rc4-mm1-GX110
> [root@spc1 steven]# mount -t reiser4 /dev/hdb1 /reiser4_testing
> mount: special device /dev/hdb1 does not exist
>
> Reading another post (and looking in /dev), I tried hdq:
>
> [root@spc1 steven]# mount -t reiser4 /dev/hdq1 /reiser4_testing
> [root@spc1 steven]# df -T
> Filesystem Type Size Used Avail Use% Mounted on
> /dev/hda1 ext3 304M 75M 214M 26% /
> /dev/hda9 reiserfs 8.3G 3.9G 4.4G 48% /home
> /dev/hda8 ext3 464M 8.1M 432M 2% /tmp
> /dev/hda6 ext3 7.4G 1.7G 5.4G 24% /usr
> /dev/hda7 ext3 1.9G 86M 1.7G 5% /var
> /dev/hdq1 reiser4 18G 217M 18G 2% /reiser4_testing
>
> Snipped from dmesg:
>
> hda: ST320423A, ATA DISK drive
> hdb: WDC WD200BB-75AUA1, ATA DISK drive
> ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
> Probing IDE interface ide1...
> hdc: SONY CD-RW CRX160E, ATAPI CD/DVD-ROM drive
> ide1 at 0x170-0x177,0x376 on irq 15
> Probing IDE interface ide2...
> Probing IDE interface ide3...
> Probing IDE interface ide4...
> Probing IDE interface ide5...
> hda: max request size: 128KiB
> hda: 40011300 sectors (20485 MB) w/512KiB Cache, CHS=39693/16/63, UDMA(66)
> hda: cache flushes not supported
> /dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 p8 p9 >
> hdb: max request size: 128KiB
> hdb: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=38792/16/63, UDMA(66)
> hdb: cache flushes not supported
> /dev/ide/host0/bus0/target1/lun0: p1
>
>
> Steven

(Replying to myself)
I decided to fix 2.6.11-rc3-mm1 with CONFIG_BASE_FULL=y and see if
the hdb/hdq confusion existed with that earlier kernel, but when I
ran lilo, I got a "Fatal: cache_add: LILO internal error" message.

[root@spc1 steven]# /sbin/lilo -v
LILO version 22.6.1, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2004 John Coffman
Released 17-Nov-2004, and compiled at 20:03:17 on Jan 15 2005

Reading boot sector from /dev/hda
Fatal: cache_add: LILO internal error

This box is still running 2.6.11-rc4-mm1 from above, and was booted
with append="root=0301" accidentally left in lilo.conf from earlier testing.

Steven

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:10    [from the cache]
©2003-2011 Jasper Spaans