[lkml]   [2005]   [Dec]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC][PATCH 1/6] RTC subsystem, class
On Mon, 26 Dec 2005 21:16:57 +0100
Pavel Machek <> wrote:

> > > > +int rtc_set_alarm(struct class_device *class_dev, struct rtc_wkalrm*alrm)
> > >
> > > Struct rtc_wake_alarm *alarm, those wovels are there for readability.
> >
> > I'm not the one who created this structure. It's defined
> > in linux/rtc.h since a long time. I can only change alrm
> > to alarm.
> Sorry if you are not responsible... Yes, alarm would be better.
> How does this relate to /proc/acpi/alarm, btw? Do they use same RTC
> alarm?

Yes, they do. The ACPI subsystem does direct I/O on the cmos clock.

Given the complexity of the ACPI code, when/if the x86 rtc driver
will be ported to the RTC subsystem, it would be wise
to disable the alarm part if ACPI is compiled in.


Best regards,

Alessandro Zummo,
Tower Technologies - Turin, Italy

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-12-27 04:18    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean