lkml.org 
[lkml]   [2005]   [Dec]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [Alsa-devel] 2.6.15-rc6: boot failure in saa7134-alsa.c


    On Wed, 21 Dec 2005, Steve deRosier wrote:
    >
    > Thankfully, we've never had to deal with this sort of failure; all of our Alsa
    > drivers and services have been well behaved (mostly).

    Yes, I think the common case is that built-in _does_ work. I certainly
    have used sound that way. This one case is a bit special just because it's
    not under the sound/ directory, but I suspect that may be true of some USB
    sound"cards" too.

    Now, hot-plug devices tend to have a stronger case for being built as
    modules, although even there I personally actually end up just building in
    the devices I have (whether cardbus cards or things like the USB
    printer/mouse/keyboard).

    So I don't think sound is terminally broken here, just a few small details
    that it gets wrong that causes some odder drivers to not like being built
    in.

    Linus
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2009-11-18 23:46    [W:0.027 / U:0.300 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site