lkml.org 
[lkml]   [2005]   [Dec]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: sata_uli fails to see harddisks on an ASRock 939Dual-SATA2 board
Date
Hi,

On Wednesday, 14 December 2005 15:01, Bernhard Rosenkraenzer wrote:
> On an ASRock 939Dual-SATA2 board, the sata_uli driver recognizes the onboard
> SATA controller (PCI ID 10b9:5289 rev 10, Subsystem 1849:5289), but fails to
> see an attached harddisk (the BIOS identifies the harddisk correctly, so a
> hardware failure is unlikely). sata_uli apparently sees _something_ is
> attached, but doesn't get further. dmesg says:
>
> libata version 1.20 loaded.
> sata_uli 0000:00:12.1: version 0.5
> GSI 18 sharing vector 0xD1 and IRQ 18
> ACPI: PCI Interrupt 0000:00:12.1[A] -> GSI 19 (level, low) -> IRQ 209
> ata1: SATA max UDMA/133 cmd 0xEC00 ctl 0xE082 bmdma 0xD880 irq 209
> ata2: SATA max UDMA/133 cmd 0xE000 ctl 0xDC02 bmdma 0xD888 irq 209
> ata1: SATA link up 1.5 Gbps (SStatus 113)
> scsi0 : sata_uli
> ata2: SATA link down (SStatus 0)
> scsi1 : sata_uli
>
> No disks are found, even though the link (on ata1) is detected.
>
> Verified both with an x86 and an x86_64 kernel, and both 2.6.15-rc5 and
> 2.6.15-rc5-mm2.

I have exactly the same board and 2.6.15-rc5/x86-64 works for me (no problems
with detecting SATA drives on SATA1 ports). The drives are jumper-forced to
SATA1, though, and I haven't tried the SATA2 controller.

Greetings,
Rafael


--
Beer is proof that God loves us and wants us to be happy - Benjamin Franklin
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-12-14 22:12    [W:0.165 / U:0.592 seconds]
©2003-2011 Jasper Spaans. Advertise on this site