lkml.org 
[lkml]   [2005]   [Nov]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [patch 00/43] ktimer reworked
Date
On Nov 30, 2005, at 22:32, Roman Zippel wrote:
> On Thu, 1 Dec 2005, Thomas Gleixner wrote:
>> but what we'd like to achieve as an end-result is the clear
>> separation of 'timer' vs. 'timeout' APIs. Our proposed end result
>> would be to have 'struct ktimer' for timers, and 'struct ktimeout'
>> for timeouts.
>
> Sorry, but calling it "ktimeout" would be completely wrong.
>
> "timeout" is a rather imprecise term, which can have different
> meanings depending on the context, e.g. any timer usually has a
> "timeout value", but what is meant here is a "timeout timer". So
> basically this is supposed to be about "timer" vs "timeout timer".
> [snip lengthy discussion]

If I recall correctly, this whole naming mess has been discussed to
death before, with the result that almost everybody but Roman thought
the names were perfectly clear such that a timer is _expected_ to
expire and a timeout is not, therefore timers should be optimized for
add=>run=>expire and timeouts optimized for add=>run=>remove.

Cheers,
Kyle Moffett

-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
GCM/CS/IT/E/U d- s++: a18 C++++>$ ULBX*++++(+++)>$ P++++(+++)>$ L++++
(+++)>$ !E- W+++(++) N+++(++) o? K? w--- O? M++ V? PS+() PE+(-) Y+ PGP
+ t+(+++) 5 X R? !tv-(--) b++++(++) DI+(++) D+++ G e>++++$ h*(+)>++$ r
%(--) !y?-(--)
------END GEEK CODE BLOCK------


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-12-01 05:01    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site