lkml.org 
[lkml]   [2005]   [Nov]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] pcilynx.c LIndent fixes
(I'm also sending this to lkml in case people disagree with me or I
missed something. Should we put something like this in CodingStyle as a
warning to future Lindent users?)

Things that Lindent generally screws up on:

On Tue, Nov 22, 2005 at 02:41:38AM +0000, Jens-Michael Hoffmann wrote:

> -MODULE_PARM_DESC(skip_eeprom, "Use generic bus info block instead of serial eeprom (default = 0).");
> -
> +MODULE_PARM_DESC(skip_eeprom,
> + "Use generic bus info block instead of serial eeprom (default = 0).");

String handling. I guess this is difficult to sensibly automate, but
this should really be something like:

MODULE_PARM_DESC(skip_eeprom,
"Use generic bus info block instead of serial eeprom "
"(default = 0).");

> [...]

> static struct i2c_adapter bit_ops = {
> - .id = 0xAA, //FIXME: probably we should get an id in i2c-id.h
> - .client_register = bit_reg,
> - .client_unregister = bit_unreg,
> - .name = "PCILynx I2C",
> + .id = 0xAA, //FIXME: probably we should get an id in i2c-id.h
> + .client_register = bit_reg,
> + .client_unregister = bit_unreg,
> + .name = "PCILynx I2C",
> };

That's not better :) The structure was much more readable before the
change. This is especially apparent with large structures.


Cheers,
Jody
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-11-22 17:35    [W:0.259 / U:0.032 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site