lkml.org 
[lkml]   [2005]   [Nov]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 6/9] Cleanup kmem_cache_create()
Date
On Friday 11 November 2005 01:04, Matthew Dobson wrote:
> - if (size < 4096 || fls(size - 1) == fls(size - 1 + 3 * BYTES_PER_WORD))
> + if (size < RED_ZONE_LIMIT ||
> + fls(size - 1) == fls(size - 1 + 3 * BYTES_PER_WORD))
> flags |= SLAB_RED_ZONE|SLAB_STORE_USER;

I would suggest sth. like

if (size < RED_TONE_LIMIT
|| fls(size - 1) = fls(size - 1 + 3 * BYTES_PER_WORD))
flags |= SLAB_RED_ZONE | SLAB_STORE_USER


Reason: A binary operator in front is a huge hint
that this is a continued line.

Just compare when you go to a store next time.

1
+ 2
- 3
* 4

is much more readable then

1 +
2 -
3 *
4

right?


Regards

Ingo Oeser


[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-11-11 09:13    [W:0.082 / U:1.708 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site