[lkml]   [2005]   [Oct]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: kernel freeze (not even an OOPS) on remount-ro+umount when using quotas

    On Fri, 7 Oct 2005, Michael Tokarev wrote:

    > This is something that has biten me quite successefully
    > in last few days... ;)
    > To make a long story short:
    > # mke2fs -j /dev/hda6
    > # mount -o usrquota /dev/hda6 /mnt
    > # cp -a /home /mnt # to make some files to work with
    > # quotacheck -uc /mnt
    > # quotaon /mnt
    > # mount -o remount,ro # this is the important step!
    > # ls -l /mnt /mnt/home # to do "something" (also important)
    > # umount /mnt
    > At this time (attempting to umount the read-only filesystem with quotas
    > enabled), the machine freezes without any messages on the console. No
    > OOPS, no response, no nothing - until a hard reboot (powercycle).
    > This happens on 2.6.11, 2.6.12 and 2.6.13 kernels -- ie, with "current"
    > kernel release.

    I just tried this on and was not able to reproduce your hangup.
    Have you tried turning on the nmi watchdog with "nmi_watchdog=2 lapic"?

    If this blocks interrupts while it spins, you might be able to see what's
    happening. Also if interrupts are not blocked, try out sysrq-t and

    -- Steve

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-10-07 16:24    [W:0.021 / U:17.868 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site