[lkml]   [2005]   [Jan]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    Patch in this message
    Subject[2.6 patch] 2.6.10-mm2: let I2C_ALGO_SGI depend on MIPS
    On Thu, Jan 06, 2005 at 12:22:40AM -0800, Andrew Morton wrote:
    > All 560 patches:
    > bk-i2c.patch

    There's no reason for offering a MIPS-only driver on other architectures
    (even though it does compile).

    Even better dependencies on specific MIPS variables might be possible
    that obsolete this patch, but this patch fixes at least the !MIPS case.

    Signed-off-by: Adrian Bunk <>

    --- linux-2.6.10-mm2-full/drivers/i2c/algos/Kconfig.old 2005-01-06 19:07:16.000000000 +0100
    +++ linux-2.6.10-mm2-full/drivers/i2c/algos/Kconfig 2005-01-06 19:08:22.000000000 +0100
    @@ -61,7 +61,7 @@

    config I2C_ALGO_SGI
    tristate "I2C SGI interfaces"
    - depends on I2C
    + depends on I2C && MIPS
    Supports the SGI interfaces like the ones found on SGI Indy VINO
    or SGI O2 MACE.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:09    [W:0.020 / U:2.380 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site