lkml.org 
[lkml]   [2005]   [Jan]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: [-mm patch] connector.c: make notify_lock static
From
Date
On Mon, 2005-01-31 at 13:41 +0100, Adrian Bunk wrote:
> notify_lock isn't a good name for a global lock.
> But since it's not used outside of the file, it can be made static.

You are right, Adrian, thank you.
Greg, please push it upstream.

> Signed-off-by: Adrian Bunk <bunk@stusta.de>

> --- linux-2.6.11-rc2-mm2-full/drivers/connector/connector.c.old 2005-01-31 13:09:14.000000000 +0100
> +++ linux-2.6.11-rc2-mm2-full/drivers/connector/connector.c 2005-01-31 13:09:28.000000000 +0100
> @@ -41,7 +41,7 @@
> module_param(cn_idx, uint, 0);
> module_param(cn_val, uint, 0);
>
> -spinlock_t notify_lock = SPIN_LOCK_UNLOCKED;
> +static spinlock_t notify_lock = SPIN_LOCK_UNLOCKED;
> static LIST_HEAD(notify_list);
>
> static struct cn_dev cdev;
--
Evgeniy Polyakov

Crash is better than data corruption -- Arthur Grabowski
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 14:10    [W:0.415 / U:0.976 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site