lkml.org 
[lkml]   [2005]   [Jan]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] rename device_init

Rename device_init to make it more unique. Useful when looking through
debug initcall bootlogs. While Im in the area, also make it static.

Signed-off-by: Anton Blanchard <anton@samba.org>

diff -puN drivers/block/genhd.c~rename_device_init drivers/block/genhd.c
--- gr_work/drivers/block/genhd.c~rename_device_init 2005-01-21 19:37:07.585813607 -0600
+++ gr_work-anton/drivers/block/genhd.c 2005-01-21 19:37:07.596811864 -0600
@@ -300,7 +300,7 @@ static struct kobject *base_probe(dev_t
return NULL;
}

-int __init device_init(void)
+static int __init genhd_device_init(void)
{
bdev_map = kobj_map_init(base_probe, &block_subsys);
blk_dev_init();
@@ -308,7 +308,7 @@ int __init device_init(void)
return 0;
}

-subsys_initcall(device_init);
+subsys_initcall(genhd_device_init);

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-03-22 14:09    [W:0.028 / U:0.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site