[lkml]   [2005]   [Jan]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Extend clear_page by an order parameter
    Andrew Morton writes:

    > It is, actually, from the POV of the page allocator. It's a "higher order
    > page" and is controlled by a struct page*, just like a zero-order page...

    So why is the function that gets me one of these "higher order pages"
    called "get_free_pages" with an "s"? :)

    Christoph's patch is bigger than it needs to be because he has to
    change all the occurrences of clear_page(x) to clear_page(x, 0), and
    then he has to change a lot of architectures' clear_page functions to
    be called _clear_page instead. If he picked a different name for the
    "clear a higher order page" function it would end up being less
    invasive as well as less confusing.

    The argument that clear_page is called that because it clears a higher
    order page won't wash; all the clear_page implementations in his patch
    are perfectly capable of clearing any contiguous set of 2^order pages
    (oops, I mean "zero-order pages"), not just a "higher order page".

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 14:09    [W:0.022 / U:7.456 seconds]
    ©2003-2017 Jasper Spaans. hosted at Digital OceanAdvertise on this site