lkml.org 
[lkml]   [2004]   [Sep]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.6.9-rc2-mm4 and nvidia 1.0-6111
The usual patches applied that made it work with -mm3.
Changed all instances of NV_REMAP_PAGE_RANGE to NV_REMAP_PFN_RANGE and
nv_remap_page_range to nv_remap_pfn_range in nv.c, nv-linux.h,
os-agp.c and os-interface.c as redifined in
/usr/src/linux-2.6.9-rc2-mm4/include/linux/mm.h.
The module builds and installs without problems, but on init 5, I get
thrown back to vt1, /var/log/XFree86.0.log gives the error:-
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xE1000000
(II) NVIDIA(0): NVIDIA GPU detected as: GeForce FX 5200
(--) NVIDIA(0): VideoBIOS: 04.34.20.42.01
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(II) NVIDIA(0): Detected AGP rate: 8X
(EE) NVIDIA(0): Failed to allocate config DMA context
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.
Fatal server error:
no screens found
-------------------------------
Any help appreciated, also posted to nvidia forum.
Regards
Sid.
--
Sid Boyce .... Hamradio G3VBV and keen Flyer
=====LINUX ONLY USED HERE=====
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-03-22 14:06    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site