lkml.org 
[lkml]   [2004]   [Sep]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: OOM & [OT] util-linux-2.12e
    Hi Olaf :)

* Olaf Hering <olh@suse.de> dixit:
> > then /etc/mtab can die. Comments? Better solutions?
> Andries, /etc/mtab is obsolete since the day when /proc/self/mounts was
> introduced. So, kill it today from your mount binary! TODAY. ...

Bad idea... ;))) I upgraded my 'mount' yesterday. I was using a
mount from Debian, from 1998 more or less, that worked flawlessly
except for the '--bind' feature and things like those. I used
/etc/mtab as a symlink to /proc/mounts, and all worked OK except for
the double root entry and the need to manually call losetup to delete
unused /dev/loop entries.

But after the upgrade I no longer could umount a filesystem that
I mounted as 'user', because the device is a symlink and the 'user'
option is not stored in /proc/mounts. So my problems were:

> - the 'user' option for umount must be handled in some way
> - loop mounts do not map to the real filename, users cant open the
> device node to run losetup on it. I think it will also get relative
> path names.
> - fix all broken apps that still rely on mtab. like GNU df(1)

Exactly!!! I will add the double root filesystem entry (one from
the device, the other one being 'rootfs / rootfs rw 0 0'). Until all
these problems are solved, is not a good idea to remove /etc/mtab :(

I have another issue with a chroot environment I have, which has
its own copy of proc and devpts mounted. Those appear in /proc/mounts
twice, but not in /etc/mtab (they appear in the /etc/mtab copy of the
chroot env).

Raúl Núñez de Arenas Coronado

--
Linux Registered User 88736
http://www.pleyades.net & http://raul.pleyades.net/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:06    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site