lkml.org 
[lkml]   [2004]   [Sep]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Weird problem when compiling kernel
On Wed, Sep 01, 2004 at 09:50:04AM -0300, Mart?n Chikilian wrote:
> Hello linux-kernel:
> I'm running Linux Slackware 10.0, kernel 2.6.7. I compiled such kernel
> when using Slackware 9.1, and after i *upgraded* to 10.0 and tried to
> compile 2.6.8.1, i noticed that i couldn't do that. When i wanted to
> modify my 2.6.7 configuration and tried to compile it again, i noticed
> that i couldn't do it either.
> I tried with all flavors off gcc, binutils, etc
> So, there is my prob.
> Error is:
> *rm -rf .tmp_versions
> mkdir -p .tmp_versions
> make -f scripts/Makefile.build obj=scripts/basic
> make -f scripts/Makefile.build obj=scripts
> make -f scripts/Makefile.build obj=arch/i386/kernel
> arch/i386/kernel/asm-offsets.s
> make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
> make -f scripts/Makefile.build obj=init
> make -f scripts/Makefile.build obj=usr
> ld -m elf_i386 -r -o usr/built-in.o
> ld: no input files
> scripts/Makefile.build:229: *** [usr/built-in.o] Error 1
> Makefile:600: *** [usr] Error 2
> --
> When make V=1.
> .config is in http://jumper.bounceme.net:81/slackatefn/.config
>
> gcc version: 3.4.1, make: 3.80, binutils: 2.15.90.0.3
> I would appreciate any help/suggestion/hint.


Please try to do:
rm usr/*o
make V=1
and post output.

Also please check that you have gzip in your path.


Your .config was far away from a valid 2.6.8.1 .config??

Sam
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:05    [from the cache]
©2003-2011 Jasper Spaans