[lkml]   [2004]   [Aug]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: PATCH: fix some 32bit isms
On Sat, Aug 07, 2004 at 12:03:05AM +0100, wrote:
> > It should be %zu, since size_t is unsigned.
> >
> > %zd is appropriate for ssize_t.
> It's signed (and not a ssize_t, while we are at it). If you want to be
> pedantic, use %td since we are dealing with ptrdiff_t here.


We are not doing homegrown offsetof(), so it's really size_t. My apologies.

Yes, that should be> %zu (OTOH, %zd will do the same unless we have 2Gb
struct somewhere ;-)

> BTW, we ought to add 't' modifier in vsnpritf()...
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 14:05    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean