lkml.org 
[lkml]   [2004]   [Jun]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectPROBLEM: Heavy iowait on 2.6 kernels
From
Date
I recently discovered why my new Gentoo server slows to a crawl on a
intermediate load on the 2.6 kernel series. The reason seems to be an
unusual amount of iowait.
I can reproduce this on two systems, one with a KT400 and and one with
Sis735 chipset.

iostat -c 1 (or vmstat) while running something like bonnie produces
iowaits of 99%.
Any 2.6 kernel responds the same (regardless of the patchset), even
vanilla. (2.6.5-mm, 2.6.6-mm, 2.6.6-vanilla and 2.6.5-gentoo-r1).
Any 2.4-series kernel is fine.

This is a sample iostat output
--
avg-cpu: %user %nice %sys %iowait %idle
26.73 0.00 10.89 62.38 0.00
avg-cpu: %user %nice %sys %iowait %idle
0.00 0.00 13.00 87.00 0.00
avg-cpu: %user %nice %sys %iowait %idle
1.01 0.00 16.16 82.83 0.00
avg-cpu: %user %nice %sys %iowait %idle
0.00 0.00 11.88 88.12 0.00
avg-cpu: %user %nice %sys %iowait %idle
0.00 0.00 1.01 98.99 0.00
avg-cpu: %user %nice %sys %iowait %idle
0.99 0.00 2.97 96.04 0.00
--
--
______________________________________________________________________
Guy Van Sanden
http://unixmafia.port5.com

Registered Linux user #249404 - September 1997
______________________________________________________________________
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:03    [from the cache]
©2003-2011 Jasper Spaans