lkml.org 
[lkml]   [2004]   [May]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: Input system and keycodes > 256
    From
    Date
    On Thu, 2004-04-29 at 01:48, Andries Brouwer wrote:
    > On Mon, Apr 26, 2004 at 02:18:07AM +0200, Benoit Plessis wrote:
    >
    > > When grabbing with 'showkey -s' nothing appear
    > > When grabbing with 'showkey' i got keycodes like '0x00 0x82 0xd0 | 0x80
    > > 0x82 0xd0' (i got same keycodes when pressing mouse buttons except those
    > > are in 0x82 0x90 -> 0x82 0x97 range)
    >
    > What version of showkey are you using?
    showkey: (console-tools) 0.2.3
    (maybe modified by debian: console-tools_0.2.3dbs-52)

    Actually while working with the Input Event system for my mouse under
    Xfree (started by hacking moudev to support eigth button mouse and
    remove the 'double' press on my Forward button (one press from the
    Logitech Cruise mode, and another from the conversion in mousedev (and
    not accurate), and after that creating an Input Event mouse driver for
    XFree) i found another weird thing (not investigated for now): All
    'extra' keys of the Keyboard (the standard one: play/pause/mail/... and
    the new which doesn't work) generate events on the same device than the
    mouse (but the normal keys goes to another event device).

    --
    Benoit Plessis <benoit@plessis.info> +33 6 77 42 78 32
    <benoit.plessis@univ-lemans.fr> <benoit.plessis@tuxfamily.org>
    <maverick@tuxfamily.org> <maverick@maverick.eu.org>
    1024D/B4D74B76 B9A7 3697 661D 25FB A609 E69E 92CA FFAB B4D7 4B76


    [unhandled content-type:application/pgp-signature]
    \
     
     \ /
      Last update: 2005-03-22 14:02    [W:0.029 / U:60.032 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site