lkml.org 
[lkml]   [2004]   [May]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: xfs partition refuses to mount
On Sat, 29 May 2004, Vincent van de Camp wrote:
>Thanks for the information. The debug option certainly was not intentional.
>I have tried fsck.xfs, but that didn't do anything but print a version
>message. I haven't tried xfs_repair. I didn't know of it's existance.
>That's definately something to try out next time, though.

fsck.xfs is a nop. It intentionally doesn't do anything... if you've
reached a point where the filesystem *needs* to be checked and repaired,
you don't want any part of it to be automated.

And most distro's these days will needlessly run fsck everytime it's
been shutdown "improperly" (where "improperly" is defined as a file
didn't get deleted.)

--Ricky


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:03    [from the cache]
©2003-2014 Jasper Spaans. Advertise on this site