lkml.org 
[lkml]   [2004]   [May]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectforcedeth breaks X in Debian-testing 2.4.25 on MSI K7N2 Delta-L mobo
    Date: Mon, 10 May 2004 21:08:06 +0200
From: Carl-Daniel Hailfinger <c-d.hailfinger.kernel.2004@gmx.net>

foner+x-forcedeth@media.mit.edu wrote:

You could have googled for "forcedeth". The first hit would have given you
all the information you need. Quoting from there:

| Send any reports to linux-kernel or netdev@oss.sgi.com and CC:
| Carl-Daniel Hailfinger <c-d.hailfinger.kernel.2004@gmx.net> to get
| the remaining issues fixed.
You know, I looked at that page at least 3 separate times on different
days, and missed that paragraph -every- time. It also doesn't help
that my next try was to google for
forcedeth bug
and
forcedeth bugs
but that page doesn't mention the word "bug" -anywhere- and hence
fails to show up when someone is looking precisely for where to file
bug reports. You might want to rephase "send any reports" to be
'send any bug reports" or "send bugs and other reports" so that google
can find the page when people are trying to report a bug.

I'm not sure how to make the paragraph itself more prominent once
someone lands on the page---all I know is that -I- couldn't find it
until I knew it was there and searched for "netdev" via my browser.
Dunno why; I'm not blind or illiterate... :)

> obviously short-term address of one of its maintainers and an address
> of another author gleaned a random mailing list. Doesn't it have its
> own buglist? Lots of googling has failed to turn one up and its
Forcedeth is integrated into current 2.4 and 2.6, so there is no point in
setting up a dedicated mailing list for it.

Okay.

> I'm now in the state where I can reliably cause X to not start if
> forcedeth is loaded, and vice versa. Logfiles for both cases are
> appended below.
>
> Does anyone know of a workaround? It looks like forcedeth is doing
> something fishy that's breaking X's VESA handling. Googling for
forcedeth only accesses the nForce nic. If that confuses the VESA BIOS
code, the bug most probably is in the BIOS itself.

So do you (or anyone) have any suggestions for what to do? This is a
reasonably new motherboard (I don't think it has any new firmware
versions out yet) and this leaves me dead in the water---all I can do
at this point is to just try the nVidia drivers and hope they work
better than forcedeth. (And I'll have to make sure that forcedeth
does -not- get loaded; I'm not yet sure how to ensure that.)

I also don't -know- that's what's going on---all I know is the various
errors (and eventual abort) I get from X if I try to start it up with
forcedeth loaded.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:03    [from the cache]
©2003-2011 Jasper Spaans