lkml.org 
[lkml]   [2004]   [Apr]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH COW] sys_copyfile
On Mon, Apr 26, 2004 at 11:20:45AM +0200, J?rn Engel wrote:
> Adds a new syscall, copyfile() which does as the name sais.

I think it's actually better to use sendfile() rather then creating a
new syscall:

ssize_t sendfile(int out_fd, int in_fd, off_t *offset, size_t count)

In that way you can create the file in the usual way and copy the
contents with an already existing syscall.

IMHO sendfile() has been a wrong name in the first place, copyfd()
would have been better. Why limit it to network traffic only?


Erik

--
+-- Erik Mouw -- www.harddisk-recovery.com -- +31 70 370 12 90 --
| Lab address: Delftechpark 26, 2628 XH, Delft, The Netherlands
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 14:02    [W:1.705 / U:0.520 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site